WordPress at a glance
function is not described

Automattic\Jetpack\Autoloader\jpfd0d177b2d8140b4b20d4474b07b8ed7

Version_Selector::is_version_update_required() public WC 1.0

Checks whether the selected package version should be updated. Composer development package versions ('9999999-dev' or versions that start with 'dev-') are favored when the JETPACK_AUTOLOAD_DEV constant is set to true.

{} It's a method of the class: Version_Selector{}

No Hooks.

Return

true|false. Returns true if the selected package version should be updated, else false.

Usage

$Version_Selector = new Version_Selector();
$Version_Selector->is_version_update_required( $selected_version, $compare_version );
$selected_version(string) (required)
The currently selected package version.
$compare_version(string) (required)
The package version that is being evaluated to determine if the version needs to be updated.

Code of Version_Selector::is_version_update_required() WC 5.3.0

<?php
public function is_version_update_required( $selected_version, $compare_version ) {
	$use_dev_versions = defined( 'JETPACK_AUTOLOAD_DEV' ) && JETPACK_AUTOLOAD_DEV;

	if ( is_null( $selected_version ) ) {
		return true;
	}

	if ( $use_dev_versions && $this->is_dev_version( $selected_version ) ) {
		return false;
	}

	if ( $this->is_dev_version( $compare_version ) ) {
		if ( $use_dev_versions ) {
			return true;
		} else {
			return false;
		}
	}

	if ( version_compare( $selected_version, $compare_version, '<' ) ) {
		return true;
	}

	return false;
}