WordPress at a glance
function is not described

WP_REST_Plugins_Controller::update_item_permissions_check() public WP 5.5.0

Checks if a given request has access to update a specific plugin.

{} It's a method of the class: WP_REST_Plugins_Controller{}

No Hooks.

Return

true/WP_Error. True if the request has access to update the item, WP_Error object otherwise.

Usage

$WP_REST_Plugins_Controller = new WP_REST_Plugins_Controller();
$WP_REST_Plugins_Controller->update_item_permissions_check( $request );
$request(WP_REST_Request) (required)
Full details about the request.

Changelog

Since 5.5.0 Introduced.

Code of WP_REST_Plugins_Controller::update_item_permissions_check() WP 5.5.1

<?php
public function update_item_permissions_check( $request ) {
	require_once ABSPATH . 'wp-admin/includes/plugin.php';

	if ( ! current_user_can( 'activate_plugins' ) ) {
		return new WP_Error(
			'rest_cannot_manage_plugins',
			__( 'Sorry, you are not allowed to manage plugins for this site.' ),
			array( 'status' => rest_authorization_required_code() )
		);
	}

	$can_read = $this->check_read_permission( $request['plugin'] );

	if ( is_wp_error( $can_read ) ) {
		return $can_read;
	}

	$status = $this->get_plugin_status( $request['plugin'] );

	if ( $request['status'] && $status !== $request['status'] ) {
		$can_change_status = $this->plugin_status_permission_check( $request['plugin'], $request['status'], $status );

		if ( is_wp_error( $can_change_status ) ) {
			return $can_change_status;
		}
	}

	return true;
}