WordPress at a glance
function is not described

WP_Scripts::all_deps() WP 2.1.0

Determines script dependencies.

This is a method of the class: WP_Scripts

Hooks from the method
Return

true/false. True on success, false on failure.

Usage

$WP_Scripts = new WP_Scripts();
$var = $WP_Scripts->all_deps( $handles, $recursion, $group );
$handles(mixed) (required)
Item handle and argument (string) or item handles and arguments (array of strings).
$recursion(true/false)
Internal flag that function is calling itself.
Default: false
$group(int/false)
Group level: (int) level, (false) no groups.
Default: false

Notes

  • See: WP_Dependencies::all_deps()

Changelog

Since 2.1.0 Introduced.

Code of WP Scripts::all deps: wp-includes/class.wp-scripts.php WP 5.3.2

<?php
public function all_deps( $handles, $recursion = false, $group = false ) {
	$r = parent::all_deps( $handles, $recursion, $group );
	if ( ! $recursion ) {
		/**
		 * Filters the list of script dependencies left to print.
		 *
		 * @since 2.3.0
		 *
		 * @param string[] $to_do An array of script dependency handles.
		 */
		$this->to_do = apply_filters( 'print_scripts_array', $this->to_do );
	}
	return $r;
}