WordPress at a glance
function is not described

user_can_create_post() WP 1.5.0

Deprecated in 2.0.0. It is no longer supported and can be removed in future releases. Use current_user_can() instead.

Whether user can create a post.

  • See: current_user_can()

No Hooks.

Return

true/false.

Usage

user_can_create_post( $user_id, $blog_id, $category_id );
$user_id(int) (required)
$blog_id(int)
Not Used
Default: 1
$category_id(int)
Not Used
Default: 'None'

Code of user can create post: wp-includes/deprecated.php WP 5.2.2

<?php
function user_can_create_post($user_id, $blog_id = 1, $category_id = 'None') {
	_deprecated_function( __FUNCTION__, '2.0.0', 'current_user_can()' );

	$author_data = get_userdata($user_id);
	return ($author_data->user_level > 1);
}