WordPress at a glance
function is not described

user_can_edit_post() WP 1.5.0

Deprecated in 2.0.0. It is no longer supported and can be removed in future releases. Use current_user_can() instead.

Whether user can edit a post.

  • See: current_user_can()

No Hooks.

Return

true/false.

Usage

user_can_edit_post( $user_id, $post_id, $blog_id );
$user_id(int) (required)
$post_id(int) (required)
$blog_id(int)
Not Used
Default: 1

Code of user can edit post: wp-includes/deprecated.php VER 5.1.1

<?php
function user_can_edit_post($user_id, $post_id, $blog_id = 1) {
	_deprecated_function( __FUNCTION__, '2.0.0', 'current_user_can()' );

	$author_data = get_userdata($user_id);
	$post = get_post($post_id);
	$post_author_data = get_userdata($post->post_author);

	if ( (($user_id == $post_author_data->ID) && !($post->post_status == 'publish' && $author_data->user_level < 2))
			 || ($author_data->user_level > $post_author_data->user_level)
			 || ($author_data->user_level >= 10) ) {
		return true;
	} else {
		return false;
	}
}