WordPress at a glance
function is not described

wp_update_core() WP 2.7.0

Deprecated in 3.7.0. It is no longer supported and can be removed in future releases. Use Core_Upgrader instead.

This was once used to kick-off the Core Updater.

Deprecated in favor of instantating a Core_Upgrader instance directly, and calling the 'upgrade' method.

No Hooks.

Return

Nothing (null).

Usage

wp_update_core( $current, $feedback );

Code of wp update core: wp-admin/includes/deprecated.php VER 5.0.3

<?php
function wp_update_core($current, $feedback = '') {
	_deprecated_function( __FUNCTION__, '3.7.0', 'new Core_Upgrader();' );

	if ( !empty($feedback) )
		add_filter('update_feedback', $feedback);

	include( ABSPATH . 'wp-admin/includes/class-wp-upgrader.php' );
	$upgrader = new Core_Upgrader();
	return $upgrader->upgrade($current);

}