WordPress at Your Fingertips
function is not described

WC_Admin_Setup_Wizard::should_show_theme() protected WC 1.0

Deprecated from version 4.6.0. It is no longer supported and can be removed in future releases. It is recommended to replace this function with the same one.

The theme "extra" should only be shown if the current user can modify themes and the store doesn't already have a WooCommerce theme.

{} It's a method of the class: WC_Admin_Setup_Wizard{}

No Hooks.

Return

true|false.

Usage

// protected - for code of main (parent) or child class
$result = $this->should_show_theme();

Changelog

Deprecated 4.6.0

Code of WC_Admin_Setup_Wizard::should_show_theme() WC 5.9.0

protected function should_show_theme() {
	_deprecated_function( __CLASS__ . '::' . __FUNCTION__, '4.6.0', 'Onboarding is maintained in WooCommerce Admin.' );
	$support_woocommerce = current_theme_supports( 'woocommerce' ) && ! wc_is_wp_default_theme_active();

	return (
		current_user_can( 'install_themes' ) &&
		current_user_can( 'switch_themes' ) &&
		! is_multisite() &&
		! $support_woocommerce
	);
}