WordPress at a glance
function is not described

WC_REST_Payment_Gateways_V2_Controller::update_items_permissions_check() public WC 1.0

Check whether a given request has permission to edit payment gateways.

{} It's a method of the class: WC_REST_Payment_Gateways_V2_Controller{}

No Hooks.

Return

WP_Error|true/false.

Usage

$WC_REST_Payment_Gateways_V2_Controller = new WC_REST_Payment_Gateways_V2_Controller();
$WC_REST_Payment_Gateways_V2_Controller->update_items_permissions_check( $request );
$request(WP_REST_Request) (required)
Full details about the request.

Code of WC_REST_Payment_Gateways_V2_Controller::update_items_permissions_check() WC 5.0.0

<?php
public function update_items_permissions_check( $request ) {
	if ( ! wc_rest_check_manager_permissions( 'payment_gateways', 'edit' ) ) {
		return new WP_Error( 'woocommerce_rest_cannot_edit', __( 'Sorry, you are not allowed to edit this resource.', 'woocommerce' ), array( 'status' => rest_authorization_required_code() ) );
	}
	return true;
}