WordPress at Your Fingertips
function is not described

WC_WCCOM_Site_Installer_Requirements_Check::met_requirements() public WC 1.0

Check if the site met the requirements

{} It's a method of the class: WC_WCCOM_Site_Installer_Requirements_Check{}

No Hooks.

Return

true|false|WP_Error. Does the site met the requirements?

Usage

$result = WC_WCCOM_Site_Installer_Requirements_Check::met_requirements();

Code of WC_WCCOM_Site_Installer_Requirements_Check::met_requirements() WC 5.6.0

public static function met_requirements() {
	$errs = array();

	if ( ! self::met_wp_cron_requirement() ) {
		$errs[] = 'wp-cron';
	}

	if ( ! self::met_filesystem_requirement() ) {
		$errs[] = 'filesystem';
	}

	if ( ! empty( $errs ) ) {
		// translators: %s: Requirements unmet.
		return new WP_Error( 'requirements_not_met', sprintf( __( 'Server requirements not met, missing requirement(s): %s.', 'woocommerce' ), implode( ', ', $errs ) ), array( 'status' => 400 ) );
	}

	return true;
}