deprecated_function_trigger_error filter-hookWC 7.3.0

This is a WordPress - deprecated_function_trigger_error hook. The plugin just uses it.

Filters whether to trigger an error for deprecated functions. (Same as WP core)

Usage

add_filter( 'deprecated_function_trigger_error', 'wp_kama_deprecated_function_trigger_error_filter' );

/**
 * Function for `deprecated_function_trigger_error` filter-hook.
 * 
 * @param bool $trigger Whether to trigger the error for deprecated functions.
 *
 * @return bool
 */
function wp_kama_deprecated_function_trigger_error_filter( $trigger ){

	// filter...
	return $trigger;
}
$trigger(true|false)
Whether to trigger the error for deprecated functions.
Default: true

Changelog

Since 7.3.0 Introduced.

Where the hook is called

Bootstrap::deprecated_dependency()
deprecated_function_trigger_error
woocommerce/src/Blocks/Domain/Bootstrap.php 454
if ( ! apply_filters( 'deprecated_function_trigger_error', true ) ) {

Where the hook is used in WooCommerce

Usage not found.